tech note

インフラ技術や車についてつぶやいていくブログ

NexusでVPCを組む必要最小限のコマンド例

featureで使用したい機能を有効化

feature telnet
feature interface-vlan
feature lacp
feature vpc
feature lldp

MGMT設定

interface mgmt0
ip address 10.2.0.11/24

※対向機は10.2.0.12/24
※この時点でtelnet経由の設定が可能となります。

Vlan設定

vlan 200

MGMTのRoute設定

vrf context management
ip route 0.0.0.0/0 10.2.0.1

VPC Domain設定

vpc domain 1
peer-switch
role priority 100
peer-keepalive destination 10.2.0.12 source 10.2.0.11
auto-recovery

VPC Peer-Link設定

interface Ethernet1/51-52
switchport mode trunk
channel-group 51 mode active

interface port-channel51
switchport mode trunk
spanning-tree port type network
speed 10000
vpc peer-link

InterfaceをMLAGしてみる

interface Ethernet1/1
channel-group 1 mode active


interface port-channel1
switchport mode trunk
vpc 1

確認コマンド

show vpc